Is a gem ready for Rails 4 or 5?

Rails 4: 615 ready, 38 not ready, and 433 unknown
Rails 5: 163 ready, 11 not ready, and 912 unknown

Gems ready for Rails 5

Name Status Rails 4 Notes Rails 4 Status Rails 5 Notes Rails 5 Status or notes updated
rubocop ready

Does not depends on Rails

ready

does not depend on Rails

11 months ago
rubocop-rspec ready

Running on our 4.2 app for some time

ready

Not dependent on rails

11 months ago
sass-rails ready

_

ready

since gem version 5.0.5

over 3 years ago
scenic ready

-

ready

5.2 from master, 5.1 from v1.4.0, 5.0 from v1.1.0 (at least, could be earlier)

11 months ago
scientist ready

Not dependent on Rails

ready

Not dependent on Rails

11 months ago
sdoc ready

does not depend on Rails

ready

does not depend on Rails

11 months ago
seedbank ready

See https://github.com/james2m/seedbank/pull/28

ready

see https://github.com/james2m/seedbank#rails-5x

almost 3 years ago
seed-fu ready

since version 2.3.0

ready

since version 2.3.6

over 3 years ago
select2-rails ready

See Jose's comment

ready

since Harry's comment below

almost 3 years ago
shoulda ready

per README for 4.2

ready

per README, at least for 5.0

11 months ago
shoulda-matchers ready

ready since gem version 2.4.0 (source)

ready

since gem version 4

8 months ago
shrine ready

https://github.com/janko-m/shrine/blob/master/CHANGELOG.md

ready

https://github.com/janko-m/shrine/blob/master/CHANGELOG.md

over 2 years ago
sidekiq ready

source

ready

does not depend on Rails

11 months ago
sidekiq-cron ready

works with Activejob (Rails 4.2+) and has been present and working in our app for years.

ready

Probably ready: there are live stories of people using it with rails 5.

11 months ago
sidekiq-pro ready

Not dependent on Rails

ready

Not dependent on Rails

11 months ago
simple_form ready

working from gem version 3.0.0

ready

since version 3.2.1

about 3 years ago
sinatra ready

Does not depend on Rails.

ready

does not depend on Rails

11 months ago
skylight ready

running in our 4.2 app for some time

ready

5.2 from v2.0.2 5.1 from v2.0.0 5.0 from v1.0.0

11 months ago
smarter_csv ready

running on our 4.2 app for some time

ready

Not dependent on Rails

11 months ago
spring ready

It's Rails core.

ready

from gem version 2.0.0 - though there is this bug: https://github.com/rails/spring/issues/485

11 months ago